[Fwd: Re: [GAP Forum] Help Configuring GAP Packages on iBook 900 MHz]

Justin C. Walker justin at mac.com
Sun Feb 10 21:26:14 GMT 2008

Dear Jeffrey and Forum,

On Feb 9, 2008, at 19:33 , Jeffrey Rolland wrote:
> Justin C. Walker wrote:
>> On Feb 8, 2008, at 17:31 , Jeffrey Rolland wrote:
>>> (cd src; make GNU_MP_LIB=. GNU_MP_INC=.)
>>> gcc -O3 -DLONGLONG -I../../carat/carat/include -L../../carat/ 
>>> carat/lib -DVERSION='"2.0 January 2003"' nq.o consistency.o pc.o  
>>> relations.o word.o system.o time.o addgen.o tails.o eliminate.o  
>>> engel.o glimt.o instances.o presentation.o mem.o pcarith.o  
>>> collect.o combicol.o trmetab.o gap.o -L. -o nq -lgmp -static
>>> /usr/bin/ld: can't locate file for: -lcrt0.o
>>> collect2: ld returned 1 exit status
>>> make[1]: *** [nq] Error 1
>>> make: *** [compile] Error 2
>>> The file isn't in /usr/local/lib/gap4r4/pkg/carat/carat-2.0/lib.
>> I've reproduced this on my system.  I really don't think this is a  
>> 'gmp' issue, and I would not (yet) start fooling around with fink  
>> or MacPorts.  The problem seems more basic: the fact that "- 
>> lcrt0.o" is the issue means (to me, at least) that the tool chain  
>> is really confused.
>> In the future, please include this information, since it will help  
>> diagnose this kind of problem:
>>  - hardware platform (processor, if known)
>>  - OS
>>  - OS version
>>  - GAP version and (if it's about a package) package version
>> I am running on a Mac Pro (Dual Quad Xeon, 3GHz), Mac OS X 10.4.11.
>> I tried this with Gap 4.4.10, and nq 2.2.
>> I find that my locally-built GMP is built as a 64-bit library,  
>> while nq is built 32-bit.  I think that is the problem (GMP seems  
>> to insist on 64-bit builds if it's possible).
>> Let us know what the above information is, and whether you built  
>> GMP yourself (and if not, where it came from).

> Hardware: Apple iBook G3 900 MHz

This pretty much eliminates the "64-bit" answer :-}

> OS and Version: Mac OS X 10.4.11
> GAP: 4.4.9
> NQ Version: 2.2
> GMP Version (Long Edition): OK, here's where it gets embarassing.

No need to be too embarrassed; many of us have been in the same boat  
at times :-}

> GMP Version (Short Edition): 4.2.2
> I have not tried recomiling NQ since installing GMP.

I would do that (I rebuilt GMP on my system, forcing it to 32 bits,  
and the 'nq' build completed).

If that doesn't work, post the results of

  file $XXX/libgmp*
  ar x $XXX/libgmp.a fscanf.o
  file fscanf.o
  rm fscanf.o

(XXX = path to the libraries).

Hope that helps.


Justin C. Walker, Curmudgeon-At-Large
Institute for the Enhancement of the Director's Income
Experience is what you get
   when you don't get what you want.

More information about the Forum mailing list