[Fwd: Re: [GAP Forum] Help Configuring GAP Packages on iBook 900 MHz]

Justin C. Walker justin at mac.com
Sat Feb 9 22:35:36 GMT 2008

On Feb 8, 2008, at 17:31 , Jeffrey Rolland wrote:

> Justin Walker wrote:
>> Dear Jeffrey and Forum,
>> On Feb 8, 2008, at 1:42 PM, Jeffrey Rolland wrote:
>>> Has anyone had any success getting this package to compile on Mac  
>>> OS X? I am running Tiger (OS 10.4.11) on an iBook G3 900 MHz with  
>>> 640 MB of RAM.
>> I have in the past had luck with the following egregious hack:
>>  $ sudo touch /usr/include/malloc.h
>> This creates an empty 'malloc.h' that the compiler will find.   
>> This should satisfy it, and since this file is unnecessary (at  
>> least on Mac OS X, and, I think, on many modern systems :-}), the  
>> fact that it provides no content should pass unnoticed.
>> As I say, I have tried it in the past and it's worked, but that is  
>> no guarantee.
>> Regards,
>> Justin
> <snip>
> Justin,
> Thanks, that took care of the the malloc.h problem.
> Now, I have a new problem. Make complains that it can't find a  
> certain file in the carat directory:
> (cd src; make GNU_MP_LIB=. GNU_MP_INC=.)
> gcc -O3 -DLONGLONG -I../../carat/carat/include -L../../carat/carat/ 
> lib -DVERSION='"2.0 January 2003"' nq.o consistency.o pc.o  
> relations.o word.o system.o time.o addgen.o tails.o eliminate.o  
> engel.o glimt.o instances.o presentation.o mem.o pcarith.o  
> collect.o combicol.o trmetab.o gap.o -L. -o nq -lgmp -static
> /usr/bin/ld: can't locate file for: -lcrt0.o
> collect2: ld returned 1 exit status
> make[1]: *** [nq] Error 1
> make: *** [compile] Error 2
> The file isn't in /usr/local/lib/gap4r4/pkg/carat/carat-2.0/lib.

I've reproduced this on my system.  I really don't think this is a  
'gmp' issue, and I would not (yet) start fooling around with fink or  
MacPorts.  The problem seems more basic: the fact that "-lcrt0.o" is  
the issue means (to me, at least) that the tool chain is really  

In the future, please include this information, since it will help  
diagnose this kind of problem:
  - hardware platform (processor, if known)
  - OS
  - OS version
  - GAP version and (if it's about a package) package version

I am running on a Mac Pro (Dual Quad Xeon, 3GHz), Mac OS X 10.4.11.

I tried this with Gap 4.4.10, and nq 2.2.

I find that my locally-built GMP is built as a 64-bit library, while  
nq is built 32-bit.  I think that is the problem (GMP seems to insist  
on 64-bit builds if it's possible).

Let us know what the above information is, and whether you built GMP  
yourself (and if not, where it came from).


Justin C. Walker, Curmudgeon-At-Large
Institute for the Enhancement of the Director's Income
When LuteFisk is outlawed,
Only outlaws will have LuteFisk

More information about the Forum mailing list