[Fwd: Re: [GAP Forum] Help Configuring GAP Packages on iBook 900 MHz]

Jeffrey Rolland rollandj at uwm.edu
Sat Feb 9 01:31:24 GMT 2008

Justin Walker wrote:
> Dear Jeffrey and Forum,
> On Feb 8, 2008, at 1:42 PM, Jeffrey Rolland wrote:
>> Has anyone had any success getting this package to compile on Mac OS 
>> X? I am running Tiger (OS 10.4.11) on an iBook G3 900 MHz with 640 MB 
>> of RAM.
> I have in the past had luck with the following egregious hack:
>  $ sudo touch /usr/include/malloc.h
> This creates an empty 'malloc.h' that the compiler will find.  This 
> should satisfy it, and since this file is unnecessary (at least on Mac 
> OS X, and, I think, on many modern systems :-}), the fact that it 
> provides no content should pass unnoticed.
> As I say, I have tried it in the past and it's worked, but that is no 
> guarantee.
> Regards,
> Justin



Thanks, that took care of the the malloc.h problem.

Now, I have a new problem. Make complains that it can't find a certain 
file in the carat directory:

(cd src; make GNU_MP_LIB=. GNU_MP_INC=.)
gcc -O3 -DLONGLONG -I../../carat/carat/include -L../../carat/carat/lib 
-DVERSION='"2.0 January 2003"' nq.o consistency.o pc.o relations.o 
word.o system.o time.o addgen.o tails.o eliminate.o engel.o glimt.o 
instances.o presentation.o mem.o pcarith.o collect.o combicol.o 
trmetab.o gap.o -L. -o nq -lgmp -static
/usr/bin/ld: can't locate file for: -lcrt0.o
collect2: ld returned 1 exit status
make[1]: *** [nq] Error 1
make: *** [compile] Error 2

The file isn't in /usr/local/lib/gap4r4/pkg/carat/carat-2.0/lib.

Any suggestions/

Jeffrey Rolland
<rollandj at uwm.edu>

More information about the Forum mailing list